it-swarm-tr.com

Joomla! Nın güvenli bir sürümü var mı? 1,6 veya 1,7 kullanılabilir mi?

herhangi bir eski Joomla! 1.6.x veya 1.7.x serisi mevcut mu?

7
JacquesR

Kısa ve uzun cevap hayır. 1.6 veya 1.7 bir siteyi en güvenli sürüm olduğu için en az 2.5.x sürümüne yükseltmeniz gerekir (2.5 hızlı kullanım ömrünün sonuna yaklaşmasına rağmen). Uyumlu bir şablonunuz varsa, 3.3'e yükseltebilirsiniz.

7
Andrew Eddie

Herhangi bir Joomla web sitesi ve bunu biraz genişletmek için, her türlü yazılım, özellikle açık kaynak ve kamuya açık olan yazılımlar, maksimum güvenlik sağlamak için güncel olmalıdır.

Joomla'nın mevcut bakım yapılabilir versiyonları Joomla 2.5 ve Joomla 3.3'tür. Joomla 1.6 ve 1.7 kısa süreli sürümlerdi ve sürüm 1.5'ten 2.5'e giden yol gibi olduklarını söyleyebiliriz. Uzun süre kalmaları amaçlanmadı, bakılmıyor (= güvenlik yamaları yok, hata düzeltmesi yok, uzantı desteği yok), bu nedenle üretimde artık kullanılamazlar.

Güncellemeler, yeni özellikler ekleyebilmeleri dışında, bilinen güvenlik açıkları ve güvenlik sorunları ile ilgileniyor. Bu güvenlik açıkları halk tarafından iyi bilinir, bu nedenle yazılımın eski bir sürümü kolayca tehlikeye atılabilir.

Aklımızda tutmamız gereken bir diğer koşul da, üçüncü taraf uzantıların bu tür eski sürümler için de korunmadığı, güvenlik açıklarına ve sunucu yazılımıyla diğer olası uyumsuzluklara daha da fazla alan sağlamasıdır.

Genellikle 1,6, 1,7'den 2,5 ve 3,3'e yükseltmek kolay bir iştir. Ancak bunun, her web sitesinin belirli koşullarına, 3. taraf uzantılarına ve olası özelleştirme düzeyine bağlı olduğunu ve

Doğrudan canlı web sitesinde yükseltme yapmaya çalışmamanız ve her zaman web sitesinin çalışan bir yedeğini tutmanız önemle tavsiye edilir.

1
FFrewin