it-swarm-tr.com

Bileşeni 2,5'ten 3,3'e geçirme

Bu belge: Joomla 1.5 uzantısını Joomla 2.5'e uyarlama

http://docs.joomla.org/Adapting_a_Joomla_1.5_extension_to_Joomla_1.6#Renamed_events

Bileşeni 2.5'e geçirdiğimde bana gerçekten yardımcı oldu.

Bileşeninizi 2.5'ten 3.3'e nasıl taşıyacağınızı gösteren benzer bir şey olup olmadığını merak ediyorum

Teşekkürler

5
Piero Marsilio

Sorunuzda sağladığınız bağlantı bile, bir uzantıyı taşırken değiştirilmesi gereken her şeyi sağlamaz. Joomla'nın her Uzun Süreli Yayın sürümü arasında her zaman oldukça büyük API farklılıkları vardır.

Joomla 3.x için, bakmaya eğilimli olduğum ana şey şudur:

Joomla 3'teki potansiyel geriye dönük uyumluluk sorunları

Buna ek olarak, en son API sitesine de bakıyorum:

http://api.joomla.org/cms-3/

Bu yardımcı olur umarım

12
Lodder

Sadece çalışmasını istiyorsanız, @Lodder tarafından sağlanan bağlantılar kullanımdan kaldırılmış kodla uğraşırken büyük ölçüde yardımcı olacaktır. 2.5.5 üzerinde çalışırken bir grup 3.x kodu desteklendi, bu yüzden sadece bu sürümü veya daha sonra destekliyorsanız, teorik olarak hem 2.5 hem de 3.x sürümlerinde çalışan bir bileşeni nispeten kolaylıkla alabilirsiniz. Belgelenmeyen, Bootstrap'e geçişle gelen düzen değişiklikleri; bunun için temel bileşenleri bir model olarak kullanmanız gerekir.

3.x özellikleri (etiketler veya içerik geçmişi gibi) için destek eklemek istiyorsanız, biraz daha iş yapmanız gerekir. Bu bağlantılar, bu özellikler için desteği entegre etmenize yardımcı olacaktır:

4
Michael

Bileşeni 2.x'ten 3.x'e geçirme

bu bağlantıya bakın,

adım 1: 2.x ile 3.x arasındaki fark

2. adım: Önemli yöntemler

2
kumarramalingam