it-swarm-tr.com

Kapatmak için hala gerekli 2.5'ten 3.x'e geçerken beni hatırla?

3.3 ve 3.2.4 ile hala eklentiyi kapatmak gerekiyor Beni hatırladın mı? Teknik neden nedir?

4
sovainfo

'Teknik nedenin ne olduğunu' yanıtlamak için izci ve GitHub notlarına bir göz attım. Sorun iki kat gibi görünüyor - yükseltme sırasında belirli dosyaların silinememesi ve belirli SQL güncellemelerinin uygulanmaması. Ancak, sadece bazılarını etkiler ve diğerlerini etkilemezse. Ek bilgi için hata izleyici konusuna bakın.

En iyi uygulama seçeneği genel yaklaşımı şu şekildedir:

Zaten tıkalı değilse ...

  • Destek olmak!
  • Devre dışı bırak System -> Remember Me Eklenti
  • Güncellemeyi yap
  • Etkinleştirme System -> Remember Me Eklenti

Bozuksa ve yedek yoksa ...

Kurulum url /administrator/index.php?option=com_joomlaupdate&task=update.finalise php hatası ile '\ plugins\system\remember\remember.php satırında' başarısız olduğunda '

\ Cli\deletefiles.php komut satırından çalıştırıldıktan sonra /administrator/index.php?option=com_joomlaupdate&task=update.finalise yenilenerek TAM BAŞARI

Bu işlem görünüşte sorunu düzeltir, ancak bunun $this->app sistem tarafından önceden doldurulmamış. Yukarıdaki başarısız olursa da bir göz atmaya değer olabilir. Bunun oldukça yeni bir çekme isteği olduğunu (16 Nisan 2014) ve izleyicide onaylanmadığını unutmayın: YMMV.

6
codinghands

Sorun henüz tam olarak bilmediğim nedenlerden ötürü sadece belirli sunucularda ortaya çıkıyor. Sunucularımda sorunsuz çalışıyor, ancak bir arkadaşımın da bu sorunu vardı.

Sorunu çözeceğine inandığım bir Halkla İlişkiler yaptım, bkz https://github.com/joomla/joomla-cms/pull/3467 . Bu sorunu olan biri bu yamayı test edebilir ve sorunu çözüp çözmediğini görebilirse, bu harika olur :-)

1
Bakual