it-swarm-tr.com

Yeni bir büyük sürüm ne zaman taşınmalı?

Yeni geliştirme stratejisi ile LTS adında bir sürüm olmayacak. Halihazırda yayınlanan bilgiler ile 3.4 açıklanan 3.5 yerini alacak. Sitelerin hangi saatte hangi sürüme taşınması beklenen 4.0,4.1,4.2,4.3,4.4 için planlar olduğu varsayılarak.

11
sovainfo

Büyük sürümler arasında geçişleri planlarken dikkate alınması gereken birkaç nokta vardır. En iyilerden biri, şu anda kullandığınız sürüm için destek sonu veya EOL tarihi olmalıdır; eğer bu yakınsa, hareketinizi planlamalısınız.

Yerleşik web siteleri için mevcut özelliklere bakmanızı öneririm. Yeni sürümde yakında ihtiyacınız olan bir şey var mı? Öyleyse, taşıma işleminizi planlamaya başlayın. Siteniz iyi çalışıyorsa ve en yeni özelliklere ihtiyaç duymuyorsa, hala desteklendiği sürece geçerli sürümde kalabilirsiniz.

Taşınıyorsanız, uzantı desteği neye benziyor? Kullandığınız uzantıların taşıdığınız sürümle uyumlu bir sürümü var mı? Öyleyse, bu işleri büyük ölçüde basitleştirir, ancak yapmazlarsa, özelliklerini başka bir şeyle değiştirmek için ne kadar çaba harcanacaktır?

Son olarak, kararlı olarak etiketlenen her sürüm, geliştirme için uygun olmalıdır, ancak şahsen X.0 veya hatta X.1 sürümünü kullanma konusunda biraz daha temkinli olacağım, çünkü bunlar genellikle kapsam kapsamında verilen hatalara daha yatkındır. büyük bir X.0 sürümüne gidebilecek değişiklik. Kişisel olarak X.2 veya X.3 sürümlerinin, büyük kullanıma hazır olma noktasına olgunlaşan bir yayın serisi görmeye başladığınızı düşünüyorum.

6
Michael

Joomla! 3.4 Her sürüm kararlı bir sürüm olacak ve yeni küçük sürüm yayınlanmayacaksa en az iki yıl destek alacaktır. Böyle bir durumda önceki küçük sürüm desteklenmeyecek ve mevcut sürüm en az iki yıl desteklenecektir. Bu nedenle, 3.x serisine geçmeyi planlıyorsanız, v3.4'ten güvende olursunuz.

Aynı durum 4.x serisi - 4.0 için de geçerlidir ve kararlı olacaktır ve yeni küçük sürüm piyasaya sürülmedikçe en az iki yıl destek alacaktır (örneğin 4.1). Böylece 4.x serisinin küçük sürümlerine geçebilirsiniz. Ancak, her büyük sürümün geriye dönük uyumsuz değişikliklere sahip olduğunu unutmayın! Dolayısıyla bu göç çok dikkatli bir şekilde planlanmalıdır.

Elbette BETA veya RC sürümlerine geçmemelisiniz, çünkü bunlar sadece test amaçlıdır.

1
Dmitry Rekun

Anladığım kadarıyla, 3.4'ten başlayarak her zaman en son sürümü kullanmalısınız, çünkü yayınlanmasından sonra 2 yıl boyunca destek alacak ve eski sürümlere (3.3, ...) destek kesilecektir. Bir serideki (3.x) tüm sürümler geriye dönük olarak uyumlu olacaktır, bu nedenle bir güncelleme genellikle sorun olmamalıdır.

Yeni 4.x serisi geriye dönük uyumluluğu bozacaktır ve yalnızca yeni özellikleri kullanmak istiyorsanız yükseltme yapmanız gerekir.

0
fruppel
  1. Geliştirmeye başlarsanız, mevcut en son ana sürümü kullanın (varsa 4 serisini kullanın)
  2. Yeni bir küçük sürüm (3.4) yayınlandığında, geçerli sürümünüzün (3.3) desteklenmesini bekleyin. Yeni sürümün kritik hata düzeltmeleri alması gerekirdi. Böylece web siteniz artık güvenle güncellenebilir.

İpucu: Her zaman aynı sunucu kurulumuyla bir test sitesi bulundurun, önce test etmek için, ardından sürümü kullanın.

0
Shyam